Skip To The Main Content
Forums / MeshWorks Software / MeshWorks Software Suit can't detect the network

MeshWorks Software Suit can't detect the network

2 posts, 0 answered
  1. yilezhou avatar
    yilezhou
    1 posts
    Registered:
    19 Jun 2015
    25 Jun 2015
    Hi

    I plugged the node 1 device into my computer and the driver just worked fine. However, when I refreshed the network map in MeshWorks software suit, it couldn't detect the network, and the device name is Unknown. I tried to update some python script to the node 1 device, but the event log kept saying "could not find an available channel and panid - status: 0xAB, starting over". Could you please tell me how to fix this problem?

    The node 2 worked pretty well with MeshWorks Software suit and it was able to run the scripts.

    Thanks.
  2. vreinhardt avatar
    vreinhardt
    53 posts
    Registered:
    08 Jul 2014
    21 Jul 2015 in reply to yilezhou
    Hi Yilezhou,

    Since Sensor Node 2 and the Gateway are working.  Can you right click on Sensor Node 2 and read back the script.  Click on Enable Remote Operations in the Network Map and type in the password "MeshWorks123".  Make sure celPy.ApplicationName is the same for both.

    Make sure celPy.ApplicationName is the same for Node 1 as well.

    With your gateway powered connect Sensor Node 1 to your computer and select the new com port at the bottom of the GUI.  Can you try issuing a "network leave" and "debug restart" on Sensor
    Node1.

    Commands are typed in the Event Log in the blank space provided.

    Give this about 30 seconds to find the new network.  It can take up to 10 mins for new nodes to find the gateway in large networks but I don't know why you are having this issue.

    Regards,

    -Vince